Why does my raw water pump look like this?

Moderators: warmrain, mimoza

Why does my raw water pump look like this?

Postby sv_bruadair » Thu Mar 25, 2010 11:08 pm

I finally have internet access after almost three months so I thought I would post this question. I only have internet for a week.

I was doing my regular maintenance and noticed that the raw water pump was covered in a patina colored 'dust'. The engine zinc, prop zinc and hull zinc are all in good condition. Is there anything I should be worried about or look at? I got it cleaned up before I checked my impeller.

Thanks for any feedback
You do not have the required permissions to view the files attached to this post.
Damon and David
s/v Bruadair
1984 HC33 #58
www.bruadair.us
www.sv-bruadair.blogspot.com

Out cruising somewhere in Colombia or Panama
User avatar
sv_bruadair
First Mate
 
Posts: 354
Joined: Mon Sep 04, 2006 5:16 am

Postby svnakia » Fri Mar 26, 2010 2:54 am

I would say it looks like that because it is slowly leaking salt water.

Take it apart and clean all the gasket surfaces. Put in new gaskets and use grease on the gaskets instead of using them dry or with another sealant. This makes it easy to take it apart next time as well as sealing the gaskets.

Maybe that will work, that's what I do and I haven't had a problem with slow leaks for a while.

John

http://svnakia.blogspot.com
svnakia
Crew
 
Posts: 53
Joined: Tue Oct 23, 2007 12:07 am


Return to Yanmar

Who is online

Users browsing this forum: No registered users and 1 guest